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PREFACE

About this manual

This manual covers the installation, configuration and connection of
the Easysoft SQI-Unisys LINC Developer Driver, and provides a
short exercise to demonstrate its operation.

I n t e n d e d A u d i e n c e

This manual is intended for use by anyone who is familiar with
Unisys LINC Development Assistant III (LDA III) and Microsoft
Windows systems, who wishes to install and use the Easysoft SQI-
Unisys LINC Developer Driver.

D i s p l a y i n g t h e M a n u a l

This manual is available in the following formats:

• Portable Document Format (PDF), which can be
displayed and printed using the Acrobat Reader, available
free from Adobe at http://www.adobe.com .

• HTML (the format Easysoft recommend for viewing
onscreen).

http://www.adobe.com
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N o t a t i o n a l C o n v e n t i o n s

Across the range of Easysoft manuals you will encounter passages
that are emphasized with a box and a label.

A note box provides additional information that may further your
understanding of a particular procedure or piece of information
relating to a particular section of this manual:

A reference box refers to resources external to the manual, such as
a useful website or suggested reading:

A platform note provides platform-specific information for a particular
procedure step:

A caution box is used to provide important information that you
should check and understand, prior to starting a particular procedure
or reading a particular section of this manual:

NB Note boxes often highlight information that you may need
to be aware of when using a particular feature.

REF For more manuals that use this convention, see the rest of
the Easysoft documentation.

Linux In Linux you must log on as the root user in order to make many
important changes.

Caution! Be sure to pay attention to these paragraphs because Caution
boxes are important!
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P R E F A C E
About this manual

T y p o g r a p h i c a l C o n v e n t i o n s

To avoid ambiguity, typographic effects have been applied to certain
types of reference:

• User interface components such as icon names, menu
names, buttons and selections are presented in bold, for
example:

Click Next to continue.

Where there is a chain of submenus, the following convention is

used:

Choose Start > Programs > Command Prompt .

• Commands to be typed are presented using a monotype

font, for example:

At the command prompt type admin .

• Keyboard Commands

It is assumed that all typed commands will be committed by

pressing the <Enter> key, and as such this will not normally be

indicated in this manual. Other key presses are italicized and

enclosed by angle brackets, for example:

Press <F1> for help.

• File listings and system names (such as file names,
directories and database fields) are presented using the
monotype plain text style.
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C o n t e n t s

• Introduction

Begins with a basic introduction to LDA III, and introduces the

Easysoft SQI-Unisys LINC Developer Driver.

• Installation

A step-by-step guide to installing the software.

• Configuration

Explains configuration options for the Easysoft SQI-Unisys LINC

Developer Driver.

• Connection

Provides three short exercises that demonstrate connecting to

data sources via the Easysoft SQI-Unisys LINC Developer

Driver.

• Demonstration

Contains two exercises to consolidate the information presented

so far.

• Appendices

Comprising a Glossary.
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P R E F A C E
About this manual

T r a d e m a r k s

Throughout this manual, Windows refers generically to Microsoft
Windows 95, 98, 2000, NT or XP, which are trademarks of the
Microsoft Corporation. The X Window system is specifically
excluded from this and is referred to as The X Window System or
just X.

Easysoft and Easysoft Data Access are trademarks of Easysoft
Limited.
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INTRODUCTION 1
Int roducing the Easysof t SQI-Unisys LINC Developer Dr iver

The Easysoft SQI-Unisys LINC Developer Driver connects any
ODBC (Open DataBase Connectivity) compliant application for
Microsoft Windows 95, Windows NT or Windows 2000, to the LDA III
Runtime Database. A suitable ODBC client (such as Microsoft
Query) then permits ad hoc data creation, update and enquiry.

This section briefly describes LDA III itself, and how the Easysoft
SQI-Unisys LINC Developer Driver can make access to this data
both easier and more flexible.

C h a p t e r G u i d e

• About LINC Development Assistant III

• LDA III Development

• LDA III Runtime

• Introducing the Easysoft SQI-Unisys LINC Developer
Driver
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A b o u t L I N C D e v e l o p m e n t A s s i s t a n t I I I

LINC Development Assistant III (LDA III) by Unisys offers LINC
users an environment that allows design, development, testing and
implementation of a LINC System completely within Windows.

Figure 1: LINC Development Assistant III schematic

LDA III provides users with the following Windows environments:

• LDA III Development

• LDA III Runtime
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I N T R O D U C T I O N
Introducing the Easysoft SQI-Unisys LINC Developer Driver

L D A I I I D e v e l o p m e n t

LDA III Development environment allows design prototyping and
development of LINC systems, which can then be transferred to a
host once complete.

Three modes of operation are supported:

• single-user, using a stand-alone system.

• single-user, using a networked system accessing a
network based repository.

• multiple-users, using a networked system accessing a
network based repository.

L D A I I I R u n t i m e

The LDA III Runtime environment allows the developed LINC
System to be run on a Windows system for test purposes. It uses a
collection of applications to implement the LDA III Runtime
environment.

These applications connect to a repository that may be on the local
machine or on a mounted network drive. The LDA repository stores
a model of the business that is being automated, along with multi-
user environment information. It is broken into business segments.
In theory, a business segment is simply a segment of the business
model. In practice, it normally corresponds to a LINC System
project.

LDA III uses various configuration setting (.INI) files to specify the
development environment, but this manual refers only to the location
of the LINCDB.INI , normally found in the LDA III repository.
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The LINCDB.INI contains the location of the runtime database and
information relating to each transaction screen Ispec within the LDA
III environment. It consists of a sequence of sections, each of which
contains the path to the database and a set of Ispec paths:

Figure 2: An example LINCDB.INI

REF
In LDAIII Development, choose Help > Contents . Double-
click on Configuration Files > Configuration Files . An
explanation of the functions of the .INI files is given here,
with diagrams.
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I N T R O D U C T I O N
Introducing the Easysoft SQI-Unisys LINC Developer Driver

LDA Viewer, another Unisys product, permits the browsing of data,
but not modification. Since the LDA III Runtime Database uses non-
standard D-ISAM database structures, there has been no browser
capable of viewing and modifying arbitrary LDA III databases.

I n t r o d u c i n g t h e E a s y s o f t S Q I - U n i s y s L I N C
D e v e l o p e r D r i v e r

The Easysoft SQI-Unisys LINC Developer Driver allows you to begin
using any ODBC compliant application to create, update and/or view
data held within the LDA III Runtime Database.

Figure 3: The Easysoft SQI-Unisys LINC Developer Driver schematic
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By creating an ODBC Data Source Name (DSN) attached to
Easysoft SQI-Unisys LINC Developer Driver, you can transparently
access the LINCDB.INI file and obtain the runtime database and
table information relating to a specific Ispec (or multiple Ispecs)
within the LDA III environment.

The Easysoft SQI-Unisys LINC Developer Driver allows you to
define how you handle:

• date formatting

• profiles

• profile flags

• LDA MAINT status and physical deletions

• overriding the directory settings in LINCDB.INI

• selection of a single database from the many possibly
defined in LINCDB.INI

• advanced options relating to specific ODBC compliant
applications

The Easysoft SQI-Unisys LINC Developer Driver also allows you to:

• use Microsoft Excel to examine information entered or
updated in the LDA III Runtime Database.

• use Microsoft Access to enter test data, via a form or SQL
insert query, into the LDA III Runtime Database.

• use Microsoft Access queries to extract data from a live
SQL-Server database, translate and then load the
resulting data directly into the LDA III Runtime Database
for test purposes.
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INSTALLATION 2
Insta l l ing the Easysof t SQI-Unisys LINC Developer Dr iver

Installing the Easysoft SQI-Unisys LINC Developer Driver will enable
you to make your LDA III Runtime Database visible as an ODBC
DSN.

This section covers the tasks necessary to install and remove the
Easysoft SQI-Unisys LINC Developer Driver.

C h a p t e r G u i d e

• Obtaining the Easysoft SQI-Unisys LINC Developer
Driver

• Installing the Easysoft SQI-Unisys LINC Developer
Driver

• Licensing the Easysoft SQI-Unisys LINC Developer
Driver

• Uninstalling the Easysoft SQI-Unisys LINC Developer
Driver
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O b t a i n i n g t h e E a s y s o f t S Q I - U n i s y s L I N C
D e v e l o p e r D r i v e r

1. There are three ways to obtain the Easysoft SQI-Unisys LINC
Developer Driver:

• The Easysoft web site is available 24 hours a day at
http://www.easysoft.com for downloads of definitive
releases and documentation. Select Download from the
Free Trials page on the Easysoft SQI-Unisys LINC
Developer Driver section of the website, and then choose
the platform release that you require. First time visitors
must complete the new user form and click Register . Note
that your personal Internet options may require you to
login and click Continue if you have previously registered.

• The Easysoft FTP server is available 24 hours a day at
ftp://ftp.easysoft.com . It contains free patches,
upgrades, documentation and beta releases of Easysoft
products, as well as definitive releases. The FTP site is
useful if you have a slow connection or if you want to write
a script to retrieve the file. Change to the pub/lda

directory and then choose the platform release that you
require.

• If you have an extremely slow connection you can order
Easysoft software on CD by email, telephone or post (see
Contact Details ).

2. Whichever medium you choose, the Easysoft SQI-Unisys LINC
Developer Driver and its install program are contained in a single
executable file, named EasysoftDataAccessForLDAIII .exe.

http://www.easysoft.com/contact/main.phtml#contact
http://www.easysoft.com
ftp://ftp.easysoft.com
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I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

I n s t a l l i n g t h e E a s y s o f t S Q I - U n i s y s L I N C
D e v e l o p e r D r i v e r

1. Execute the EasysoftDataAccessForLDAIII .exe file.

There will be a short delay while setup prepares the wizard to guide
you through the rest of the install procedure. You will then be
presented with the Welcome screen.

2. Click Next when you have read the Welcome screen. If you agree to
the Licence Agreement then click Yes to continue with the
installation.

You will then be presented with information relating to this release of
the Easysoft SQI-Unisys LINC Developer Driver.

– OR –

If you do not agree with the licence agreement click No and refer to
Easysoft License Agreement for more information.

3. Read the information relating to this release and click the Next
button.

The install program then displays the User Information dialog box:

Caution! As a precaution, check that all ODBC and LDA III programs are
shut down before commencing the installation.

http://www.easysoft.com/legal/license.phtml?solution=0101
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Figure 4: The User Information dialog box

4. Enter your name and the name of your company in the relevant
fields and click Next .

You will then be presented with the Choose Destination Location
dialog box.
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I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

S P E C I F Y I N G T H E I N S T A L L L O C A T I O N

Figure 5: The Choose Destination Location dialog box

5. Click Next to install the application into the default directory location
C:\Program Files\Easysoft\

Easysoft Data Access for LDA III .

– OR –

Click Browse and select an alternative directory location for the
installation, before clicking Next .

You will then be informed that the necessary files are being installed,
before being presented with the pre-configured DSN dialog box.
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C R E A T I N G T H E S A M P L E _ L D A I I I D A T A S O U R C E

Figure 6: An example Easysoft SQI-Unisys LINC Developer Driver Data
Source dialog box

6. Click OK to accept the default configuration of the DSN
Sample_LDAIII . The specifics of the configuration of this type of
DSN are discussed further in "Configuration" on page 31 .

NB
Do not click Check For Updates at this stage. This dialog
box is discussed in more detail in "Configuration" on
page 31 .
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I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

The Install program runs the Easysoft licensing manager, which
presents the License Manager dialog box (see Figure 7 on page
23).

L i c e n s i n g t h e E a s y s o f t S Q I - U n i s y s L I N C
D e v e l o p e r D r i v e r

Figure 7: The Easysoft License Manager dialog box
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1. Enter your name in the Name text box.

You can choose whether to request a license by email, by phone or
fax, or by a direct internet connection to easysoft.com. If you already
purchased the software you will need your authorisation key to
hand.

2. Enter your email address in the E-Mail address box.

If you have registered at the easysoft web site before, then you
should enter the exact same address that you registered with. This
will help us in providing you with support.

3. Enter your correct company name in the Company text box.

4. Enter your telephone and fax details in the next two text boxes.

Again, this will be sent to Easysoft to help us provide product
support.

5. Click Request Key to begin adding the license for the Easysoft SQI-
Unisys LINC Developer Driver.

The License Manager asks you what sort of key you would like to
request.

NB
You must obtain a license to use the Easysoft SQI-Unisys
LINC Developer Driver. If you have obtained the software
for evaluation purposes, you can obtain a trial license at
this point.



25

I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

Figure 8: The License Manager License Type Selection dialog box

6. If you are installing the software for evaluation purposes, select Trial
and click Next . Skip to step 8 on page 25 .

– OR –

If you have purchased the software, select Purchase and click
Next .

7. You are prompted for your license number. Enter it and click Next .
Skip to step 9 on page 25 .

8. In the drop-down list box, select the Easysoft SQI-Unisys LINC
Developer Driver. Click Next .

9. You are now presented with a dialog box summarising the
information you have entered so far. There are three buttons for
submitting a license request.
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Figure 9: The License Request Submission dialog box

You can click Online Request to send a request directly by the
internet to Easysoft. This is the quickest method and results in your
details being entered immediately into our support database.

– OR –

If you entered your email address, you can click E-mail Request to
submit your request by email.

– OR –

You can click on Print Request to print off the information for faxing
or phoning-in your request.
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I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

10. You have now requested a license. You will receive a key by email or
phone which you can use to activate the license (see "Enabling an
Easysoft License" on page 28 ).

You are returned to the main License Manager dialog box, which
now contains details of the licenses you requested. Click Finish .
You are then presented with the Setup Complete dialog box:

Figure 10: The Setup Complete dialog box

11. You may be informed that your computer needs to be rebooted prior
to using the Easysoft SQI-Unisys LINC Developer Driver. If this is
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the case ensure that the option Yes has been checked and then
click the Finish button to complete the installation.

– OR –

Check the No option, and then click the Finish button..

E N A B L I N G A N E A S Y S O F T L I C E N S E

Enabling an Easysoft license is easy. If you recieved your license
key in an email, then you can simply execute the attachment and
your licenses will automatically have their keys applied.

If you received the license key by phone or on paper then you must
enter it by hand into the Easysoft License Manager.

1. Select Start > Programs > Easysoft > Easysoft Data Access
Licensing > License Manager .

You are presented with the License Manager dialog box (see Figure
7 on page 23 ).

2. Click on Enter License .

3. In the text box, type your license key.

4. Click Apply .

You have now licensed your Easysoft product.

Caution!
If you choose to continue working by clicking the No option, be sure
to restart Windows before attempting to configure or use Easysoft
SQI-Unisys LINC Developer Driver.
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I N S T A L L A T I O N
Installing the Easysoft SQI-Unisys LINC Developer Driver

U n i n s t a l l i n g t h e E a s y s o f t S Q I - U n i s y s L I N C
D e v e l o p e r D r i v e r

If required you can uninstall the Easysoft SQI-Unisys LINC
Developer Driver.

1. Select Start > Settings > Control Panel and then double-click the
Add/Remove Programs icon.

You will then be presented with a list of applications that can be
automatically removed.

2. Select Easysoft SQI-Unisys LINC Developer Driver and click the
Add/Remove button.

3. Click Yes to confirm that you are sure you wish to remove the
Easysoft SQI-Unisys LINC Developer Driver and all its components.

The system will then begin to remove all the components. If shared
components seem no longer to be required, then you will be
prompted to decide whether or not to delete them.

4. If you feel confident with the registry (i.e. your system has had
relatively few programs installed and removed) you should click the
Yes button to proceed.

– OR –

If you have any doubts you should click the No or No to All buttons.

NB

Windows’ install/uninstall procedures incorporate a
mechanism in the registry to determine whether or not
shared files are still required by other programs.
Sometimes this database can become out-of-date, for
instance if the user deleted an application directly, without
using Add/Remove Programs , or there was an
undetected fault in an install script.
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The uninstall process removes the following Easysoft SQI-Unisys
LINC Developer Driver components in your system:

• Shared Program Files

• Standard Program Files

• Folder Items

• Program Folders

• Program Directories

• Program Registry Entries

5. On completion, click OK to go back to the Control Panel
Install/Uninstall window.
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CONFIGURATION 3
Conf igur ing the Easysof t SQI-Unisys LINC Developer Dr iver

This section details the configuration options for the Easysoft SQI-
Unisys LINC Developer Driver and covers all the information you
need to connect the Easysoft SQI-Unisys LINC Developer Driver to
your own LDA III data source. It is presented as a step-by-step guide
to creating a Data Source Name (DSN). The chapter covers all
cases and is useful as a reference for when you create future DSNs.

First time users, or those who wish only to connect to the DSN, may
prefer to skip to "Demonstration" on page 53 which uses a specific
example.

C h a p t e r G u i d e

• Creating a System Data Source Name

• Ensuring the Latest Version is Installed

• Accessing the Online Help
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C r e a t i n g a S y s t e m D a t a S o u r c e N a m e

1. Select Start > Setting > Control Panel and open the ODBCicon.

You will then be presented with the ODBC Data Source
Administrator window.

2. Click on the System DSN tab.

3. Click the Add button. Windows then prompts you to select a data
source driver.

4. Select the Easysoft LDA III driver and click Finish .

The Easysoft SQI-Unisys LINC Developer Driver Configuration
dialog box appears.

2000
To find the ODBC icon in Windows 2000, open
Administrative Tools in Control Panel. The ODBC icon is
called Datasources (ODBC) .

NB
Note that if a User DSN is created, it will only be available
to the user on that system who created that DSN. By
creating a System DSN it is made available to all users on
this system.
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Figure 11: The Easysoft SQI-Unisys LINC Developer Driver Setup dialog box

5. Choose a suitable name for your data source, and enter it in the
Datasource box.

6. Enter an appropriate Description for this DSN.

The description may be displayed in DSN selection dialog boxes.
For example, Miscrosoft’s Data Source Manager displays the
description field next to the data source name when you create link
tables in Access 97.
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S P E C I F Y I N G T H E L O C A T I O N O F T H E L I N C D B . I N I
F I L E

7. Specify the location of your chosen LINCDB.INI in the Directory
box. You can select the directory with the mouse by clicking the
Browse button.

D E T E R M I N I N G T H E D A T E F O R M A T T O B E A P P L I E D

Choose the required Date Format to indicate how the driver should
interpret dates stored in the runtime database files.

8. Check International if the LDA III database stores dates in the
formats YYMMDD or YYYYMMDD.

– OR –

Check US for the formats MMDDYY or MMDDYYYY.

– OR –

Check UK if you wish to use the formats DDMMYY or DDMMYYYY.

NB

LDA III uses the file LINCDB.INI to coordinate the files
that form a repository (see Figure 2 on page 14 ).
Easysoft SQI-Unisys LINC Developer Driver exploits this
to minimize the amount of path information you need to
supply to the driver. You need to specify the location
because there may be more than one LINCDB.INI on
your system.

Caution!
Be sure to check the correct date format, since a mismatch
between the ODBC driver and the LDA III database will not only
result in the display of scrambled dates, but could lead to incorrect
values in the database file.
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D E T E R M I N I N G P R O F I L E R E C O R D S E L E C T I O N
C R I T E R I A

The profile is the means by which an index to the data is provided,
where the data collectively performs a specific function. In simple
terms, a profile presents data in either a raw format (an Ispec profile)
or a filtered format.

Additionally profiles may have conditional logic applied to them. For
instance, you would apply conditional logic to indicate a specific
month against that profile in order to access sales data for a given
month.

9. If you wish to make available the Ispec profile information alone,
check the Ispec option.

– OR –

If you wish to access the Ispec information along with any profiles
that do not have conditional logic applied to them, check the Non-
Conditional option.

– OR –

NB

The Easysoft SQI-Unisys LINC Developer Driver
automatically detects whether or not century information is
stored by examining the length of the field. It will always
return a standard ODBC date to the client, regardless of
the underlying format. Beware that if short dates are used
in the LDA III database then the underlying Unisys date
format is only good for dates up to 2050.
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If you wish to access the Ispec information along with any profiles
that have conditional-logic applied to them, check the Conditional
option.

– OR –

If you wish to access all profiles, regardless of their nature, then you
should check the All option. The table below summarises the
options.

Figure 12: Profile Record Selection criteria

D E T E R M I N I N G P R O F I L E F L A G O P T I O N C R I T E R I A

In the LDA III repository, each profile in an Ispec is flagged with Y or
N to indicate whether data is to be included in the profile or not. You
may wish to make this visible to the ODBC client for debugging
purposes.

10. Check the Visible profile flags option if you wish profile flags to be
visible to the ODBC client.

D E T E R M I N I N G L D A M A I N T S T A T U S C R I T E R I A

The MAINT status is a single character reflecting the most recent
action by LINC on that data, either A for added (ADD), C for
changed (CHG) or D for deleted (DEL). The Easysoft SQI-Unisys
LINC Developer Driver driver maintains this field at all times, but you
can modify the driver’s behaviour when reading the field.

Option\Visible Ispec Conditional Non-Conditional

Ispec Yes

Conditional Yes Yes

Non-Conditional Yes Yes

All Yes Yes Yes
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11. Check the Use LDA MAINT option if you wish to interpret the MAINT

field. That is, records marked with a D will not be returned as they
are regarded as deleted.

– OR –

Clear the Use LDA MAINT option if you wish to display the MAINT

field, and have all data, regardless of MAINT status, made visible. In
addition any data deleted will be purged automatically.

D E T E R M I N I N G P H Y S I C A L D E L E T I O N C R I T E R I A

The Runtime Database is comprised of two layers; the LDA Layer
and the ISAM File Layer.

The behaviour of the LDA layer is governed by MAINT status.

Physical deletions occur at the ISAM file layer.

The Physical deletion option can be useful to reduce the database
size by physically removing redundant data.

12. Check the Physical deletion option if you want physical deletion in
the ISAM layer to automatically follow logical deletion in the LDA
layer.

NB

Do not write to the MAINT field using your ODBC client.
The driver still maintains this field, and altering it will, for
instance, cause Access to warn that “Another user edited
this record and saved the changes before you attempted
to save your changes”.

Caution!
The consequences of checking the Physical deletion option can
be severe. Not only will data be purged irretrievably from the ISAM
file layer, but the subsequent re-indexing may take some time for
large databases.
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O V E R R I D I N G T H E L I N C D B . I N I S P E C I F I C A T I O N S

Under certain circumstances you may want to override the directory
settings in LINCDB.INI .

For instance, if you copy a directory containing database files to
another location, you can set up a DSN to the new database location
without modifying the LINCDB.INI file.

13. You may define where the database directory is located, by checking
the Override Directory option and entering a valid directory
location.

The mechanism for overriding directories is as follows:

The LINCDB.INI file contains sections beginning with the name of
the database and the database path, followed by a series of Ispec
locations (Figure 2 on page 14 ).

If you specify an override directory, then the Easysoft SQI-Unisys
LINC Developer Driver performs a search-and-replace on the
LINCDB.INI file. It reads the DBPATH andthen replaces every
occurrence of that directory with the override directory.

S I N G L E D A T A B A S E O P T I O N

By default the DSN will connect to all databases found in the
LINCDB.INI file. If you prefer, you can restrict the driver to a
specific database. This can be useful if you connect with a client that
does not handle multiple schemas correctly: for example, Microsoft
Query cannot handle a data source where two Ispecs in different
business segments have the same name.

NB
The search-and-replace operation takes place in the
driver’s memory. No changes are made to the
LINCDB.INI file itself.
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14. Check the Single Database option and enter the name of the
database you wish to access when using this DSN. The database
name is the bracketed string at the head of each section of
LINCDB.INI , without the brackets, for example: SAMPLE.

S P E C I F Y I N G A D V A N C E D O P T I O N S

In relational databases, every table should have a primary key,
which uniquely identifies each row (record). Sometimes it is
necessary or desirable to combine fields to create this key (a
composite key). It is theoretically possible that the key for a given
table might be the entire row. The Easysoft SQI-Unisys LINC
Developer Driver uses indexing information in the repository to
decide what constitutes the table’s key on the client side.

Some ODBC clients may fail if a given key is composed of too many
fields, so the driver can generate a simple, read only, numeric key
(called ROWID) for tables whose indexing requirements are too
complex.

15. Check the Maximum Index Columns advanced option and enter a
value that relates to the application being used.

Those tables with more than this number of index columns then
have ROWIDappended, preventing an error or warning occurring
while using the DSN.

Caution!
If this advanced option is enabled, the profiles may not necessarily
present the data in the correct sequence due to the index not being
used.

NB
Regardless of the Maximum Index Columns setting, any
tables without ordinates (such as tables mapped directly
to an Ispec) will have the extra ROWIDcolumn appended,
so that each row can be uniquely identified.
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E n s u r i n g t h e L a t e s t V e r s i o n i s I n s t a l l e d

Click Check for Updates to ensure that you are using the latest
version of the Easysoft SQI-Unisys LINC Developer Driver.

This will then attempt to access the Internet from your PC and get
the latest version number from the Easysoft version server. If a later
version is available you will be informed accordingly.

The attempt to initiate a connection will instigate whatever method is
used to connect your PC to the Internet, and should this connection
fail or not be available you will be informed accordingly.

A c c e s s i n g t h e O n l i n e H e l p

Click Help to be presented with information about using the
Easysoft SQI-Unisys LINC Developer Driver configuration screen.

– OR –

Click ? (located in the title bar of the dialog box) and then click on an
individual field to learn more about a specific part of the Easysoft
SQI-Unisys LINC Developer Driver configuration screen.

Caution! If you have made changes to the DSN, click OK to commit the new
configuration information before accepting the new release.

NB

Please note that when a connection to Easysoft is
established, no information about your installed software
is sent to the Easysoft version server.

On receiving the request for version information, the
Easysoft server sends the latest number back to the
requesting host (your PC), where the configuration
software checks to see if it is the latest version.
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Having installed the Easysoft SQI-Unisys LINC Developer Driver,
you can immediately demonstrate a connection to an LDA III
Runtime Database.

This section contains exercises to demonstrate the Easysoft SQI-
Unisys LINC Developer Driver connecting to and amending data in
two LDA III data sources.

Although the exercises were created with and make reference to
Microsoft Access 97, all the exercises can be carried out with any
ODBC-compliant SQL tool.

C h a p t e r G u i d e

• Prerequisites

• Connecting to the source data Database

• Connecting to the Sample LDA III Runtime Database

• Preparing to Enter the SQL Statements

• Entering the SQL Statements

• Implementing the SQL Statements

• Using the LDA Runtime Database Test Data



C O N N E C T I O N
Connecting to the Easysoft SQI-Unisys LINC Developer Driver

42

4

P r e r e q u i s i t e s

1. This chapter assumes you have the Sample_LDAIII DSN
connected to the Easysoft sample database.

2. You should have received a SAMPLEdatabase when you obtained
LDA III from Unisys. Make sure that:

• You have this database

• You do not mind altering the information in this database

• You know the path to its repository

3. The User DSN Sample_LDAIII , created as part of the Easysoft SQI-
Unisys LINC Developer Driver, was used with the following changes:

• The Profiles option set to Ispec

• The Maximum Index Columns option enabled and set to 10

Refer to "Creating a System Data Source Name" on page 32 for
more information on how DSNs are configured.

4. Both the sample model supplied with LDA III, and the sample
database supplied with the Easysoft SQI-Unisys LINC Developer
Driver contain the following tables:

• SAMPLE.CREDITS

• SAMPLE.CUST

• SAMPLE.CUSTINV

• SAMPLE.CUSTNAMES

• SAMPLE.DOX

• SAMPLE.EVENT

• SAMPLE.INVENTORY
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• SAMPLE.PAUDT

• SAMPLE.PRICE-CHG

• SAMPLE.PROD

• SAMPLE.PRODNAMES

• SAMPLE.RECEVABLE

• SAMPLE.REPT

• SAMPLE.SREP

• SAMPLE.SREPNAMES

• SAMPLE.VEND

• SAMPLE.VENDNAMES

• SAMPLE.VENDPROD

• SAMPLE.VPROD

C o n n e c t i n g t o t h e s o u r c e d a t a D a t a b a s e

5. Start Microsoft Access 97, create a blank database and then save it
as db_lda.mdb .

A Database window is displayed, which currently has no tables. It is
now necessary to link to the tables containing the source data.

6. Select File > Get External Data > Link Tables to begin connecting
to the sample database and its tables, installed as part of the
Easysoft SQI-Unisys LINC Developer Driver.

This displays the Link window, in which the appropriate database
can be selected.

7. From the Files of type drop-down list, choose ODBC Databases .

The Select Data Source dialog box is displayed:
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Figure 13: The Select Data Source dialog box

8. Click the Machine Data Source Tab, select Sample_LDAIII and
click OK.

The Link Tables window displays the following list of tables:

• SAMPLE.CUST

• SAMPLE.DOX

• SAMPLE.EVENT

• SAMPLE.PAUDT



45

C O N N E C T I O N
Connecting to the Easysoft SQI-Unisys LINC Developer Driver

• SAMPLE.PROD

• SAMPLE.REPT

• SAMPLE.SREP

• SAMPLE.VEND

• SAMPLE.VPROD

9. Click Select All to select all the tables shown, then click OK.

This will then link all source tables shown above, before returning to
the Database window, where the destination tables may then be
selected.

C o n n e c t i n g t o t h e S a m p l e L D A I I I R u n t i m e
D a t a b a s e

10. Select File > Get External Data > Link Tables to begin connecting
to the sample LDA III Runtime database.

This displays the Link window, in which the appropriate database
can be selected.

11. From the Files of type drop-down list, choose ODBC Databases .

This then presents the Select Data Source window.

12. Click the Machine Data Source Tab, and select LDA_DSN and click
OK.

NB
Note that the list of tables presented is not a complete
listing due to the fact that the Ispec profile option was
chosen in the Sample_LDAIII DSN.
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The Link Tables window is displayed, which due to the Ispec profile
option being chosen in this DSN, will contain the same number of
tables as displayed for the previous DSN used.

For more information please refer to "Determining Profile Record
Selection Criteria" on page 35 .

13. Click Select All to select all the tables shown, then click OK.

This will then link all the destination tables into the database before
returning to the Database window.

Figure 14: db_lda tables in the Database window

NB
Note that because the tables names are identical in both
databases, the LDA_DSN table names selected will have
the suffix 1 applied to them.
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14. Select the SAMPLE_PROD table and click Open to be shown the
data within that table.

Figure 15: Sample data within the SAMPLE_PROD table

15. Select the SAMPLE_PROD1 table and click Open to be shown that
no data exists within that table.

Figure 16: The sample linked SAMPLE_PROD1 table empty
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Appropriate SQL statements must now be used in order to populate
the empty table with the data from the populated table.

P r e p a r i n g t o E n t e r t h e S Q L S t a t e m e n t s

Although the process of populating the empty tables may be done by
either the Microsoft Access Query Wizards, the Select Query
window in Design View or by using drag-and-drop. It is also possible
to use SQL statements to perform this task.

16. Click on the Queries tab and click New.

The New Query window is displayed.

17. In order to not use query wizards select Design View and then click
OK.

18. Click Close .

This then presents the Select Query window, showing that no tables
or fields are currently defined.

19. Select View > SQL View to be presented with the Select Query
window in SQL mode, which now allows SQL statements to be
entered directly.

NB

Note that SQL statements will not be generated for use
with SAMPLE_DOXand SAMPLE_PAUDTsince, although
the tables need to exist, no records exist in these source
database tables.

In addition SAMPLE_EVENTis not used since this table is
used to track specific events within the LDA III Runtime,
such as a stock transactions, where a sale is made or
goods are received.
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E n t e r i n g t h e S Q L S t a t e m e n t s

The empty tables must now be populated from the source data
tables by using the SQL statement INSERT INTO.

20. By default the statement SELECT; is presented, this should be
deleted and replaced with the following:

INSERT INTO sample_cust1 (credlimit, [cust-type],

customer, deladd1, deladd2, deladd3, maint, nam,

postadd1, postadd2, postadd3, salesrep)

SELECT credlimit, [cust-type], customer, deladd1,

deladd2, deladd3, "A" AS maint, nam, postadd1,

postadd2, postadd3, salesrep

FROM sample_cust;

21. Having entered the statement, select File > Save and give it the
name Populate_CUST .

The remaining queries can then be created.

NB

In order for these statements to work, the sequence of
column names used in the SQL statements must be the
same sequence as they occur in both source and
destination tables. Additionally all columns must be
accounted for in the statement, regardless of whether that
column is to be populated or not.

NB

Note that in statement shown above, the source MAINT
column data has not been selected. This is due to the fact
that data is being appended to the LDA III Runtime
Database table, and thus the MAINT status flag is set to
A, regardless of its value in the source table.
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22. Create the following statement and save as Populate_PROD .

INSERT INTO sample_prod1 (maint, nam, product,

reordlev, sellprice, unitsale)

SELECT "A" AS maint, nam, product, reordlev,

sellprice, unitsale

FROM sample_prod;

23. Create the following statement and save as Populate_REPT .

INSERT INTO sample_rept1 (maint, report, reptcode)

SELECT "A" AS maint, report, reptcode

FROM sample_rept;

24. Create the following statement and save as Populate_SREP .

INSERT INTO sample_srep1 (area, maint, nam,

salesrep)

SELECT area, "A" AS maint, nam, salesrep

FROM sample_srep;

25. Create the following statement and save as Populate_VEND .

INSERT INTO sample_vend1 (maint, nam, postadd1,

postadd2, postadd3, vendor)

SELECT "A" AS maint, nam, postadd1, postadd2,

postadd3, vendor

FROM sample_vend;

26. Create the following statement and save as Populate_VPROD .

INSERT INTO sample_vprod1 (rowid, comments, maint,

product, vendor)
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SELECT rowid, comments, "A" AS maint, product,

vendor

FROM sample_vprod;

You will then need to implement the SQL statements created, in
order to begin populating the empty tables with the test data.

I m p l e m e n t i n g t h e S Q L S t a t e m e n t s

27. To implement the SQL statement and populate the empty table,
select Populate_CUST and click Open .

If confirmation messages are enabled, Microsoft Access will ask for
confirmation to run the append query and modify the relevant table.

28. Click Yes to continue.

The system will ask for further confirmation, indicating the number of
rows that are about to be appended.

29. Click Yes to continue.

30. Select the remaining queries shown below, and click Open .

31. Populate_PROD

32. Populate_REPT

33. Populate_SREP

34. Populate_VEND

35. Populate_VPROD

36. Exit Microsoft Access 97 by selecting File > Exit .

You can now use the test data residing in the LDA III Runtime
Database.
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U s i n g t h e L D A R u n t i m e D a t a b a s e T e s t D a t a

37. Select Start > Programs > LDA III > Runtime .

You will then be presented with the LDA III Runtime window.

38. Select File > Open Session .

You will then be presented with the Select a LINC System window.

39. Select the SAMPLE system name, and click OK.

This will open a session to allow you to begin testing your LINC
system, with the test data now residing in the LDA Runtime
Database.
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This section contains two exercises to consolidate the information
presented so far.

Although the exercises were created with and make reference to
Microsoft Access 97, all the exercises can be carried out with any
ODBC-compliant SQL tool.

C h a p t e r G u i d e

• Prerequisites

• Using the Easysoft Sample DSN

• Two Short Exercises
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P r e r e q u i s i t e s

1. This chapter assumes you have completed "Installation" on page
17, and thus have the Sample_LDAIII DSN connected to the
Easysoft sample database.

2. You will require an ODBC compliant SQL tool (preferably Microsoft
Access 97). If you have Microsoft Access you can ignore the text
boxes marked "SQL" in the instructions below.

3. The exercise connects to the LDA III data source that was installed
along with the Easysoft SQI-Unisys LINC Developer Driver. It does
not need LDA III installed on your system.

U s i n g t h e E a s y s o f t S a m p l e D S N

1. Start Microsoft Access and create a blank database. Call it
easysample.mdb

2. Select File > Get External Data > Link Tables to connect to the
sample database.

The Link window is displayed, showing the existing databases on
your system.

3. From the Files of type drop-down list, choose ODBC Databases .

This displays the Select Data Source dialog box.

4. Click the Machine Data Source Tab.
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Figure 17: The Select Data Source dialog box

5. Select Sample_LDAIII and click OK.

Recall that this is the name of the data source you created during
the install process (see Figure 6 on page 22 ). Microsoft Access 97
displays the Link Tables window, showing a list of available data
sets.

6. Click Select All to select all the tables shown, and then click OK.

After a short wait, you are returned to the Database window.
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7. Double-click on SAMPLE_CUSTto open the data set as a table.

Notice the MAINT field, which shows you the most recent action
performed on the record. This is present because the Use LDA
MAINT box was left unchecked during the install process.

Note also the ROWID field. This is generated by the Easysoft SQI-
Unisys LINC Developer Driver driver to guarantee a unique
reference for each row.

8. Navigate to any record that contains a C or an A in the MAINT field.

Note the value in the CUSTOMERfield and then select Edit > Delete
Record .

9. Close the datasheet and then open it again by double-clicking
SAMPLE_CUST.

Your record has returned, with a D in the MAINT field. This is
because the Easysoft SQI-Unisys LINC Developer Driver DSN is
configured with Use LDA MAINTset to off.

SQL
In general SQL, you can view a handful of the records like this:

SELECT * FROM sample_cust WHERE rowid<6;

Access
You may get a confirmation box at this point, depending on how you
have configured Microsoft Access. Confirm that you wish to perform
the deletion.

SQL

To delete a record, use:

DELETE FROM sample_cust WHERE rowid=1;

then use the SELECTstatement above for step 9 on page 56
below.
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The MAINT field is maintained but not honoured.

T w o S h o r t E x e r c i s e s

This section sets two exercises without step-by-step instructions.

They cover the key aspects of the driver, and each is presented with
a short list of points to note.

1. Change the Use LDA MAINT setting a couple of times and observe
how deletions in your client really result in data disappearing.

A few hints:

• Use Windows’ ODBC administrator (Start > Settings > Control
Panel , then the ODBC icon) to get to the Easysoft SQI-Unisys
LINC Developer Driver configuration dialog box (see “Creating a
System Data Source Name” on page 32 ).

• When making changes to a data source, some clients (e.g.
Microsoft Access) do not implement those changes immediately,
and it may be necessary to close the client or re-link the tables.

• Changing Use LDA MAINT effectively changes the description of
the table returned by removing the MAINT column.

NB

Many clients perform some degree of caching to reduce
server load, which may make it appear as if the record
really has been deleted. For instance, using Records >
Refresh in Microsoft Access will not cause the record to
return. You must close and re-open the datasheet.



D E M O N S T R A T I O N
Demonstrating the Easysoft SQI-Unisys LINC Developer Driver

58

5

In Microsoft Access the link-tables therefore need to be

deleted and recreated.

• Note that with Use LDA MAINT checked, deletions really do
disappear. They do not return when you quit and re-enter the
database.

• When Use LDA MAINT is cleared again, those deleted records
reappear, since they were never physically deleted. The rows
were concealed only because the Easysoft SQI-Unisys LINC
Developer Driver driver honoured the MAINT status field.

2. Change the Physical deletion setting and observe the change in
behaviour when deleting with your client.

• Even with Use LDA MAINT off and the MAINT column displayed,
deleted records disappear for good.

• Unchecking Physical Deletion does not result in their
reinstatement.
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GLOSSARY A
Terms and def ini t ions

API

Application Program Interface. An API is a published set of function
calls and constants allowing different programmers to utilise a ready-
written library of subroutines.

Application

An Application Program ("Application" or "App") is a program that
applies the computer to solving some real-world problem. In ODBC
terms, it is a program connecting to the data source, normally under
Microsoft Windows. Easysoft Data Access opens up the range of
platforms for ODBC applications.

Authorization code

You must have an authorization code for the Easysoft product you
wish to license in order to obtain a purchased license. When you
purchase a product your authorization code is emailed to you. You
do not need an authorization code to obtain a trial license.

Business model

By bringing together various business segments, a model of the
requirements for that part of the organisation requiring the LINC
system can be established and can directly be compared to that of
repository.

Business segment

Provides the definition for the LINC System and can be directly
compared to that of a database or schema.
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Client

A process performing tasks local to the current user, for example,
formatting and displaying a report from data retrieved from the
server.

Client/server

The name given to the architecture whereby one process (the
server) keeps track of global data, and another task (the client) is
responsible for formatting and presenting the data. The client
connects to the server and requests queries or actions be performed
on its behalf.

Column

The vertical dimension of a table. A named, typed "field" along with
all its data.

conditional profile

A profile that has conditional records in its definition. These records
define the data that should be visible within the profile. When a row
is inserted or updated in the Ispec, the conditional profiles must be
checked and the profile flag set to ‘Y’ or ‘N’ accordingly.

data source

In ODBC terms, a data source is a database or other data repository
coupled with an ODBC driver, which has been given a Data Source
Name (see “DSN” on page 61 ) to identify it to the ODBC Driver
Manager.

to download

To retrieve data from a remote machine (or "the internet") to your
local machine. Mechanisms for achieving this include FTP and the
World Wide Web.
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driver

Data Source Name. A name associated with an ODBC data source.
Driver Managers, such as the Microsoft Windows Driver Manager,
use the Data Source Name to cross-reference configuration
information and load the required driver. See also “ODBC driver”
on page 62 .

Driver Manager

A piece of software whose main function is to load ODBC drivers.
ODBC applications connect to the Driver Manager and requests a
DSN. The Driver Manager loads the driver specified in the DSN’s
configuration file. In Windows, the ODBC Data Source Administrator
is used to set up the Driver Manager.

DSN

See “data source” on page 60 .

field

A placeholder for a single datum in a record. For example you can
have a Surname field in a Contact Details record.

Ispec

The means by which a transaction is entered, either a Component
Ispec or an Event Ispec, where the transaction proposed has a
single purpose. An Ispec roughly equates to a screen in the LINC
system.

LDA

LDA (LINC Development Assistant) is a set of applications that allow
the design, development, testing and implementation of a LINC
System on a Windows platform.
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LDA Development

The part of LDA for building the LINC system.

LDA Runtime

The part of LDA for running a LINC system on the Windows
platform.

LINC

A suite of programs and methods for the rapid development of
transaction intensive systems, by Unisys.

LINC System

A suite of programs allowing data entry and the production of
reports. LINC Systems comprise multiple Ispecs.

LINCDB.INI

A configuration setting file that contains names and directories that
define the locations of the files for all business segments and Ispecs.

MAINT

A single character column containing either A for added; C for
changed or D for deleted. This is maintained by the LDA runtime and
reflects the most recent action on the given record (or row).

ODBC (Open DataBase Connectivity)

Is Microsoft’s standard API for connecting to heterogeneous
database formats from Windows programs. ODBC is available on an
number of platforms.

ODBC driver

Software that accesses a proprietary data source, providing a
standardised view of the data to ODBC.
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operating system

Academics still haven’t agreed on the actual definition of an
operating system, but a working definition can be:

A collection of software programs, APIs and working practices that
control and integrate the execution of system functions on behalf of
application programs.

platform

The term "platform" covers the hardware and operating system as a
unit, such as a PC running Microsoft Windows.

profile

Provides an index to a specified selection of data, and provides a
means of access to just those data that are required to perform a
specific function.

profile flags

A single character field, containing Y or N, that exists for each profile
in an Ispec and indicates whether or not that Ispec data is included
in the profile.

repository

A database containing details of business segments (LINC
Specifications) held by LDA. The concrete implementation of the
business model.

row

Is the horizontal dimension of a table (compare column). A row
roughly corresponds to a single entity in the real world.

schema

A specification of the structure of a database, including the tables,
their column headings and keys.
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server

A process performing the centralised component of some task, for
example extracting information from a corporate database. See
“Client/server” on page 60 .

SQL (Structured Query Language)

A standard language for interacting with relational database
systems, based on Relational Theory.

system data source

In the context of ODBC under Microsoft Windows, a data source
which can be accessed by any user on a given system. See also
“user data source” on page 64 .

table

A data set in a relational database, composed of rows and columns.
For example:

This table has two columns; vendor , and name. It has two rows,
that corresponding to Easysoft Data Access, and that corresponding
to MySoft’s ODBC client software. The term table can also apply to
just the definition of the table, without its data.

user data source

An ODBC Data Source with access limited to a specific user on a
given system. See also “system data source” on page 64 .

software

vendor name

Easysoft Easysoft Data Access

MySoft My ODBC Compliant Application
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